This incident has been resolved. We will work with affected customers directly to delete any meetings that were captured incorrectly due to this issue.
Posted Jun 03, 2026 - 23:44 UTC
Update
Our second fix, rolled out earlier today, appears to have resolved the issue. Since our recorder pods do not restart until all calls they are handling having ended, it can take upwards of 24 hours to complete a full rollout. We will hold this incident open until we can confirm that the issue is fully resolved. We will work with affected customers directly to delete any meetings that were captured incorrectly due to this issue.
Posted Jun 03, 2026 - 18:57 UTC
Update
We are continuing to monitor Microsoft Teams call recording closely.
Posted Jun 02, 2026 - 22:10 UTC
Update
We continue to monitor the situation and have seen improvements in service. While conditions have improved, some users may still be experiencing intermittent issues, and we are actively working toward a full resolution.
Posted Jun 02, 2026 - 15:22 UTC
Update
Continuing to monitor Microsoft Teams call recording closely.
Posted Jun 01, 2026 - 21:53 UTC
Monitoring
We have started rolling out a fix.
Posted Jun 01, 2026 - 10:03 UTC
Identified
We've identified an issue affecting the manual recording controls in Theta Lake's Teams app. Calls are connecting normally and all recordings are running as expected. This issue does not affect customers ability to make calls or our ability to record them. The only impact is to on-demand recording controls: while we work on a fix, users will be temporarily unable to manually start or stop a recording from within the Teams app. Default recording behavior is unaffected and continues to operate normally.
Posted Jun 01, 2026 - 07:41 UTC
This incident affected: Third Party Integrations (Microsoft Teams).