Salesforce Chatter content delayed

Incident Report for Theta Lake

Postmortem

At 2026-03-08 08:10:10 UTC, Salesforce unexpectedly invalidated all of the long-lived refresh tokens issued for the Theta Lake for Salesforce Chatter app. The problem was detected by Theta Lake's internal integration health monitoring, and we quickly escalated to Salesforce. Since the refresh tokens were irrevocably lost by Salesforce, our customer's admins had to return to our application and re-authorize the app. Theta Lake's Support team proactively coordinated with all customers with active Salesforce Chatter integrations to complete this task. Once re-authentication was completed, data ingestion picked up from where it left off at the time of the refresh token invalidation, and no data was dropped or missed. We thank our partners at Salesforce for their timely attention to this issue!

Posted Mar 13, 2026 - 19:55 UTC

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 21:28 UTC

Monitoring

A fix has been implemented and we are monitoring results. Impacted customers will be contacted with next steps.
Posted Mar 12, 2026 - 17:59 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 12, 2026 - 13:46 UTC

Investigating

Salesforce Chatter integrations are currently experiencing a delay in processing. We are investigating and working with Salesforce to remediate. There will be no data loss and content flow will resume once resolved.
Posted Mar 09, 2026 - 19:44 UTC
This incident affected: Third Party Integrations (Other).