Intermittent MS Teams Recording Issues

Incident Report for Theta Lake

Postmortem

As part of regularly scheduled maintenance, we upgraded the Microsoft Teams Recorder component to a newer version of the Microsoft Recording SDK. This update required changes to how we register for call recordings and handle media streams.

The combination of these two changes led to a situation where a small number of calls did not correctly register for media streams when asynchronous events for that call arrived in a particular order and with particular timings. As a result, this small number of calls we’re not recorded.

Our telemetry promptly detected the situation when it began to occur and alerted our on-call Operations team, who escalated and resolved the issue. We have identified the specific calls that were affected and will be reaching out directly to impacted customers with the relevant details.

Posted Jul 14, 2025 - 19:02 UTC

Resolved

This incident has been resolved. Customers in all regions are able to make and receive calls.
Posted Jul 14, 2025 - 12:24 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2025 - 10:52 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 14, 2025 - 09:25 UTC

Investigating

We're investigating a potential issue with the recording of some MS teams calls.
Posted Jul 14, 2025 - 09:20 UTC
This incident affected: US West (Ingestion & Analysis), US East (Ingestion & Analysis), ANZ (Ingestion & Analysis), EU (Ingestion & Analysis), APAC (Ingestion & Analysis), Third Party Integrations (Microsoft Teams), and UK (Ingestion & Analysis).